Lokalize

出自Ubuntu 正體中文 Wiki

跳轉到: 導航, 搜尋
Lokalize

Lokalize 於 Oxygen 佈景的圖片
舊稱
開發者 Nick Shaforostoff 等
授權 GPLv2
使用平台 Linux, Windows(KDE for Win)
最新版本 1.0
APT 套件名稱 [apt: ]
官方網站 Lokalize - KDE UserBase




目錄

簡介

Lokalize 是 KDE 上的翻譯工具。
它擁有許多翻譯輔助功能:

  • Alternate Translations(相似言語參照)
  • Glossary(使用者定義字庫)
  • Translation Memory(過去翻譯參照)

使用

建立專案

要使用 lokalize 的強大功能,你必需先建立專案。
不過目前似乎它有個 Bug ,自行建立專案會導致程式當機。[1]
這裡提供一個專案檔,如果你碰上麻煩,可以直接套用它。

[General]
AltDir=相似言語參照的資料夾位置(相對位置)
LangCode=目標語言(正體中文代號為 zh_TW)
MailingList=翻譯團隊的信箱
PotBaseDir=翻譯模板(*.pot)的位置(相對位置)
ProjectID=專案名稱

有些東西如果你不用,該行直接砍掉就可以了。
接著就是給它存在一個資料夾內,以利管理。副檔名為:lokalize,如:kde.lokalize。

設定

翻譯畫面

點選工具列上的 Project->Open Project 來開啟專案,當然一開始是沒東西,你得把 po 檔放進專案資料夾才行。
如果你想的話,在專案資料夾內另建子資料夾也是可以的。
接著,Project Overview 應該會顯示你的 po 檔,或其所在的資料夾。不過有時它不會顯示,這時你就得親自找出來。

你打開了翻譯檔,它應該是一團亂,如右圖。
畫面中的功能是可以自己移動的,如同大部分的 KDE 程式。而如果有些功能你沒看到,你可以由 Setting->Toolveiws 來開啟。

若想更近一步的了解專案的設定,點選 Project->Configure Project。
如果不想的話,直接看翻譯視窗的工具

  • General 頁
    • ID 為專案名
    • Target language 為要翻成的語言,通常為正體中文 zh_TW
    • Mailing list 為專案小組的信箱
    • Root folder 是專案資料夾
    • Glossary 是使用者定義字庫的位置,它是一個 html 檔。
  • Advanced 頁
    • Accelerator
    • Markup 用於 translation memory 的 正規表達式
    • Template files folder
      • pot 檔所在的資料夾,其內結構必需和專案資料夾相同
      • 如:你有一個 xd.po 的檔案,那麼,該資料夾內要有一個 xd.pot
      • 或者,你的 xd.po 於 資料夾 xd 內,template files folder 也要有個 xd.pot 於 xd 資料夾內
    • Branch folder 用於同步處理,如果得你和別人翻譯同一分檔案的時候用
    • Alternate translations folder
      • 相似語言的翻譯檔資料夾,我們可以用來參考其它語言的翻譯檔。其內結構必需和專案資料夾相同
      • 如:你有一個 xd.po 的檔案,那麼,該資料夾內要有一個 xd.po
      • 或者,你的 xd.po 於 資料夾 xd 內,alternate files folder 也要有個 xd.po 於 xd 資料夾內
      • 一般簡體中文的翻譯進度會比較前面,很值得使用
  • Scripts 頁
    • 目前只有一個 python 腳本,作用是能搜尋其它 KDE 程式的單字
  • Personal
    • 你在翻譯團隊中的角色,一般來說是 translator。

翻譯工具介紹

關閉小工具

還記得翻譯介面中一大堆的小視窗吧?覺得太擠的話,你可以關掉它們,訣竅就是按它們各自在右上角的 x,如右圖。
以下介紹各個小工具:

Translation Unit
要被翻譯的資料,有 Source (英文)、Target (正體中文/你的語言)。
Unit metadata
是註解,多數會顯示它來自源始碼的哪邊,可能會有一些屬性,有時可以參考。
點 Add a note 可以自己加,它也會顯示在 Translation Unit 中。
Alternate Translations
就是別的語言的翻譯,如果你有設定的話。
Alt+數字加到你的翻譯上。
Translation Memory
跟據你翻過的東西,它會給個意見,另外顯示相似度。
不過通常顯示的東西天差地遠,70%以上的相似度較有參考價值。
Ctrl+數字加到你的翻譯中。
Glossary
使用者自訂字典,在其上按滑鼠右鍵->Define new term 可以定義新的字。
完全對到的詞才會顯示,如你定義 Sceptre,若遇到 scep 就不會顯示。
加入翻譯的快速鍵是Ctrl+特定按鍵,它們依序是:E H J K P N Y { } ; '[2]

更新翻譯檔

套件是隨時間改版,舊有的翻譯有時會突然消失。
由 Project->Configure Project 中設定 Template files folder ,你就可以透過點選 File->Update file from template,來更新你的 po 檔。
當然啦,Template files folder 內要有東西。而一般來說,官方都有一個翻譯介紹處,該處會說明如何取得 pot 檔。

註解

  1. 根據 Archlinux 上的 kdemod 的狀況
  2. 可能第二個和第三個都是 H,你得到 Setting->Configure Shortcuts 中設定。

參見