必裝軟體

出自Ubuntu 正體中文 Wiki

跳轉到: 導航, 搜尋

目錄


在這個頁面中,將會簡介在安裝之後,可以讓 Ubuntu 更加好用的一些調整、及推薦安裝的軟體。

必要的修正與推薦的調整

以下指令可以直接複製,並且在「終端機」(快捷鍵為Ctrl+Alt+t)貼上後執行。

中文字型異常修正

自 8.04 到 11.04 ,Ubuntu 新增的字型設定檔「69-language-selector-zh-*.conf」不適當地混合了中文和英文的字型,導致部份軟體的中文會呈現方框。

sudo sed -i '/DejaVu/d ; /Bitstream Vera/d ; /WenQuanYi Bitmap Song/d' /etc/fonts/conf.avail/69-language-selector*

此外自 10.04 到 10.10 ,若進入「修復模式」(開機選單中的recovery mode),也會發現選單出現亂碼。這是因為修復模式無法直接顯示中文,而造成的亂碼。

sudo rm /usr/share/locale-langpack/zh*/LC_MESSAGES/friendly-recovery.mo /usr/share/locale-langpack/zh*/LC_MESSAGES/newt.mo

移除面板上的 Me 選單

從 10.04 到 11.04 ,Ubuntu 新增的一個面板元件「indecator-me」,雖然可以方便的切換 IM 及通訊軟體的狀態,但是穩定性差常常導致關機圖示顯示不正常,以下指令可以移除它。

sudo apt-get remove --purge indicator-me

更換輸入法

從 10.10 開始,預設的 ibus 輸入法裡的預設注音輸入法「新酷音」有些已知問題,例如重複輸入、反白後自動刪除等。
因此您可以安裝 gcin 或者 SCIM 來取代預設的 ibus。以下提供安裝 SCIM 的簡易方法。

sudo apt-get install scim scim-chewing && sudo im-switch -s scim-bridge

修正 Gedit 的亂碼

GNOME 中的預設文字編輯器 "Gedit" 的預設編碼識別裡沒有 Big 5 等中文編碼,導致它開啟使用 Big 5 等編碼的檔案時會呈現亂碼。

gconftool-2 -s /apps/gedit-2/preferences/encodings/auto_detected --type list --list-type string '[UTF-8,BIG5,BIG5-HKSCS,EUC-TW,CURRENT,ISO-8859-15,UTF-16]'

11.04:Compiz 與 Unity 衝突

假如發生Compiz與Unity衝突的情況,使兩者回歸預設設定後重新登入即可解決。

rm -rf ~/.compiz* ~/.config/compiz* ~/.cache/compiz* ~/.gconf/apps/compiz*

11.04:字看不清楚

在11.04中您可能會覺得字看得比較不清楚,
放心,不是你眼睛老化了,而為預設的佈景主題其文字不是設全黑而是設深灰。
請到「關機圖示>系統設定>外觀>佈景主題>自訂>顏色」調整。

Unity:改善 Firefox 選單的可用性

Unity 上方面板的選單裡滑鼠中鍵、右鍵等於左鍵,可能是為了觸控而設計,因為觸控是不分左、中、右鍵的。
但是這樣一來使用 Firefox 時,原本可在書籤中的項目按中鍵來以新分頁開啟,現在卻變成在當前頁面開啟了。
如果有人不喜歡 firefox 這樣,請執行以下指令取消將 firefox 的選單列整合至面板:

sudo apt-get remove --purge firefox-globalmenu

Unity:LiberOffice 與 Unity 整合

預設的辦公軟體 LibreOffice 的選單列並沒被整合到 Unity 面板。
假使希望它整合到面板,請在終端機輸入下列指令:

sudo apt-get install lo-menubar

Unity:更方便地切換工作區

請按Alt+F2輸入gconf-editor

到「/apps/compiz-1/plugins/vpswitch/screen0/options」
將「next_button」設為「Button5」
將「prev_button」設為「Button4」

便可在桌面空白處使用滑鼠滾輪切換工作區。

Unity:取消桌面上的掛載圖示

Unity的啟動器列可以自動顯示掛載的硬碟、光碟、隨身碟等等。
所以假如想取消在桌面顯示掛載的硬碟、光碟、隨身碟等以增加美觀,
請按Alt+F2輸入gconf-editor 後,
到 /apps/nautilus/desktop/volumes_visible 取消 volumes_visible 。

必裝軟體

由於版權或是必要性等原因, Ubuntu 的預設並沒有安裝某些我們常用的軟體。
如果您剛認識 Ubuntu ,並且安裝成功了,想要開始輕鬆地使用,我們推薦您安裝這些軟體。
而日後,如果您對其他軟體有所需求,請參考首頁上面的Ubuntu 資料分類

建議

您可以直接使用這裡的安裝指令,請在終端機貼上執行。此外,這裡的指令不包含「DVD解密」套件,此套件請依頁底的安裝方法來安裝:

sudo apt-get install lha p7zip-full unrar poppler-data gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-ugly usb-modeswitch flashplugin-installer

或者依照需求選擇

您可能不需要用到某些功能,我們提供了建議的套件清單:

如何安裝?

請先確認你已連上網路,然後安裝的方法有二:
一、最簡單的方法是直接點擊以下連結。
二、或者在終端機輸入:

sudo apt-get install 套件名稱

如果要同時安裝多個套件,則可以這樣做:

sudo apt-get install 套件1 套件2 套件3 (依此類推)

解壓縮套件

用於對lzh、7z、rar等壓縮檔進行解壓縮。
lha
p7zip-full
unrar

補完PDF檔的中文

補完文件檢視器Evince(預設的PDF檢視器)的PDF用中文字體。
poppler-data

影音解碼器

要播放非自由格式的影音檔,必須安裝的解碼器。(ex. mp3 mp4 wmv rmvb ...)
gstreamer0.10-ffmpeg
gstreamer0.10-plugins-bad
gstreamer0.10-plugins-ugly

3G行動網卡所需套件

部份3G行動網卡需要這個套件,應該在離線狀態前先裝好備妥。
usb-modeswitch

Flash動畫顯示

顯示常見的Flash動畫,Youtube等會用到。
flashplugin-installer

DVD解密

播放有CSS保護的影片DVD時需要。
請到這邊下載deb檔,32位元系統用戶請下載i386版,64位元系統用戶請下載amd64版,然後滑鼠左鍵雙擊即可安裝。

Unity 2D

有些顯示卡因為不支援OpenGL導致沒有辦法正常的開啟 Unity 標準模式,請安裝 Unity 2D 來享受新的介面:

sudo add-apt-repository ppa:unity-2d-team/unity-2d-daily
sudo apt-get update
sudo apt-get install unity-2d

在行動裝置上安裝時的輕量化

如果您把 Ubuntu 安裝在隨身碟等可儲存空間較小的裝置,可以在終端機輸入下列指令,來減少 Ubuntu 佔用的空間。 由於孤立套件、快取套件會隨著「更新系統、安裝與刪除軟體」而增加,所以這些指令當有需要時便可執行。

移除孤立套件

移除「因依賴關係而被裝上,但後來主套件已被移除而不再被需要的」孤立套件

sudo apt-get autoremove --purge

移除快取檔案

移除「更新系統或安裝軟體時下載的」快取檔案

sudo apt-get clean

反饋

如果希望使自己慣用的套件進入官方預設的話,可以做下面的設定;雖然必需人多勢眾才有影響力,但總比什麼都不做好。
請到Synaptic套件管理程式的「設定->套件庫->統計」勾取「自動提交統計資訊」。

資料來源

(分享)灌好Ubuntu後必要的修正與套件 - by xenomorph0525